Ford Taurus Owners Welcomes You!

Jump to content

Custom Search



Welcome to Ford Taurus Forum


Sign In  Log in with Facebook

Create Account
Welcome to Ford Taurus Forum, like most online communities you must register to create topics or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of Ford Taurus Forum by signing in or creating an account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album and post photos. . .more!
 
Guest Message by DevFuse

Photo
- - - - -

2003 Taurus Stalling out problem


  • Please log in to reply
1 reply to this topic

#1 OFFLINE   smarziale

smarziale

    New Taurus Member

  • Taurus Member
  • Pip
  • 1 posts

Posted 19 February 2009 - 10:30 AM

Hello, I am new to the forum. I have been having issues since November 2008 with my 2003 Taurus stalling out. The problem is very intermittent and my mechanic cannot seem to duplicate the problem. Ford dealerships have given me the runaround and now $1,000 later I am still stalling out. The Cam sensor has been replaced because that was the initial code that came up when this problem first started. Also, I replaced the crankshaft position sensor. Still stalling, hesitating and skipping and jolting while I am driving. Has anyone else experienced this? Is there a fix anywhere in my near future? Please, someone help.






Loose this advertisement by becoming a member. Click here to create a free acccount.

#2 OFFLINE   Fordtech1

Fordtech1

    New Taurus Member

  • Taurus Member
  • Pip
  • 4 posts

Posted 23 February 2009 - 04:22 PM

QUOTE (smarziale @ Feb 19 2009, 10:30 AM) <{POST_SNAPBACK}>
Hello, I am new to the forum. I have been having issues since November 2008 with my 2003 Taurus stalling out. The problem is very intermittent and my mechanic cannot seem to duplicate the problem. Ford dealerships have given me the runaround and now $1,000 later I am still stalling out. The Cam sensor has been replaced because that was the initial code that came up when this problem first started. Also, I replaced the crankshaft position sensor. Still stalling, hesitating and skipping and jolting while I am driving. Has anyone else experienced this? Is there a fix anywhere in my near future? Please, someone help.


It could be a few different things. What engine do you have? Is it the 3.0 DOHC or the 3.0 ohv.
Either way, if it is missing while driving, it shouldn't be hard to figure out. Most of the time when a taurus comes in with a skipping, missing concern, especially with moderate acceleration, its either a spark plug wire or ignition coil pack. As far as the stalling, it could be a IAC (idle air control) valve. By the way, a bad ignition coil can actually cause RF interference in the computer system and set unrelated codes and have you chasing your tail.
Hope that helps some.
Any Check engine light? Whats the codes?